Использование linux на старых 32-битных компьютерах

  • 17.04.2017
  • 1 Comment

Иногда может возникнуть необходимость использования старых компьютеров. Операционные системы Linux отлично подходят для этой задачи. В интернете можно найти множество статей и рекомендаций для подбора ПО и конкретных дистрибутивов для этой задачи. Но есть ключевая проблема: с недавних пор все браузеры (и некоторые другие программы) перестали поддерживать старые процессоры (большинство 32-разрядных).

Mozilla Firefox (с версии 48), Google Chrome (с версии 34), Skype (с версии 6.2), Adobe Flash (с версии 11.2) для работы необходим набор инструкций процессора SSE2. Все процссоры AMD до Athlon 64 и все процессоры Intel до Pentium 4 не поддерживают набор этих инструкций, соответственно, упомянутые программы или вообще не запустятся, или будут “падать” с ошибками. Проверить поддерживает ли ваш компьютер эти инструкции можно с помощью команды:

sudo lshw -C cpu | grep -i sse2

Если не поддерживает – то никакого вывода после неё не будет.

Независимо от того, какой Linux дистрибутив у вас установлен (Debian, Ubuntu, Mint, Fedora и т.д.), сколько оперативной памяти и как быстро всё в целом работает – ключевое ПО, типа браузера, может сделать ваше рабочее место непригодным для использования, в случае если ваш процессор (например, Athlon XP или Pentium 3) не поддерживает SSE2. Использование старых версий программ тоже не выход – Google Chrome и Skype старых версий не будут вообще работать, устаревший Firefox – не сможет открыть большинство современных сайтов и будет во многих случаях небезопасен или сильно тормозить.

К примеру, для минимального функционала можно использовать примитивные браузеры типа Links или SlimBoat – но в них не будет никакого видео, да и реализации большинства возможностей JavaScript.

Но, благо, решение всё же имеется.

– Браузер

На сегодня, единственный актуальный браузер без необходимости иметь поддержку SSE2 – это Palemoon специальной сборки. По ссылке вы можете скачать версию от автора этой сборки, и на всякий случай мы скопировали её и на свой сервер. Просто разархивируйте архив и запустите исполняемый файл palemoon. В нём будут работать JavaScript, современные сайты и даже видео (конечно не так быстро как на процессорах с поддержкой SSE2).

– Flash

Технологию Adobe Flash вообще лучше не использовать, но если такая необходимость имеется – можно попробовать использовать старую официальную версию или, что лучше, специальные сборки типа того, что описано здесь.

– Skype

Старые версии Skype компанией Microsoft больше не поддерживаются, они просто не будут работать. Поэтому официальный клиент Skype использовать на старом компьютере уже не получится. Но можно попробовать воспользоваться веб-клиентом (использовать Skype через web-браузер) или, если видео и аудио-связь не обязательны – можно использовать специальный плагин для клиента Pidgin.

Если у вас имеются проблемы с запуском какого-то ещё ПО на старом компьютере с Linux – пишите об этом в комментариях – мы подскажем, что с этим можно сделать.

  1. Anonymous says:

    Злакси крутой.

Leave a Comment

Your email address will not be published.